package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<greek_letter>\\?\\(?:alpha|[bz]?eta|(?:dig|g|G)amma|[Dd]elta|[Uue]psilon|[Tt]heta|iota|kappa|[Ll]ambda|[mn]u|[Xx]i|[Pp]i|rho|[Ss]igma|tau|[Pp][hs]i|chi|[Oo]mega|var(?:epsilon|theta|rho|ph?i|kappa|sigma)))`)
var str = `Include
\alpha \beta \gamma \Gamma \delta \Delta \epsilon \varepsilon \zeta \eta \theta \vartheta \Theta \iota \kappa \lambda \Lambda \mu \nu \xi \Xi \pi \Pi \rho \varrho \sigma \Sigma \tau \upsilon \Upsilon \phi \varphi \Phi \chi \psi \Psi \omega \Omega \varkappa \varpi \varsigma
Exclude
\Alpha \Beta \vargamma \Epsilon \Zeta \Eta \Iota \Kappa \Mu \Nu \Rho \Tau \Chi \varpsi \varPhi
https://www.overleaf.com/learn/latex/List_of_Greek_letters_and_math_symbols`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}