const regex = /(?<greek_letter>\\?\\(?:alpha|[bz]?eta|(?:dig|g|G)amma|[Dd]elta|[Uue]psilon|[Tt]heta|iota|kappa|[Ll]ambda|[mn]u|[Xx]i|[Pp]i|rho|[Ss]igma|tau|[Pp][hs]i|chi|[Oo]mega|var(?:epsilon|theta|rho|ph?i|kappa|sigma)))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<greek_letter>\\\\?\\\\(?:alpha|[bz]?eta|(?:dig|g|G)amma|[Dd]elta|[Uue]psilon|[Tt]heta|iota|kappa|[Ll]ambda|[mn]u|[Xx]i|[Pp]i|rho|[Ss]igma|tau|[Pp][hs]i|chi|[Oo]mega|var(?:epsilon|theta|rho|ph?i|kappa|sigma)))', 'gm')
const str = `Include
\\alpha \\beta \\gamma \\Gamma \\delta \\Delta \\epsilon \\varepsilon \\zeta \\eta \\theta \\vartheta \\Theta \\iota \\kappa \\lambda \\Lambda \\mu \\nu \\xi \\Xi \\pi \\Pi \\rho \\varrho \\sigma \\Sigma \\tau \\upsilon \\Upsilon \\phi \\varphi \\Phi \\chi \\psi \\Psi \\omega \\Omega \\varkappa \\varpi \\varsigma
Exclude
\\Alpha \\Beta \\vargamma \\Epsilon \\Zeta \\Eta \\Iota \\Kappa \\Mu \\Nu \\Rho \\Tau \\Chi \\varpsi \\varPhi
https://www.overleaf.com/learn/latex/List_of_Greek_letters_and_math_symbols`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}