using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[case #(?>[0-9a-f]){7}\] )";
string input = @"[case #2ef4a9b]
[case #2ef4a9b]
[case #96be035]
[case #fc043fa]
[case #2ed20ad]
[case #7131fec] ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}