const regex = /(\[case #(?>[0-9a-f]){7}\] )/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[case #(?>[0-9a-f]){7}\\] )', 'gm')
const str = `[case #2ef4a9b]
[case #2ef4a9b]
[case #96be035]
[case #fc043fa]
[case #2ed20ad]
[case #7131fec] `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}