import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[case #(?>[0-9a-f]){7}\\] )";
final String string = "[case #2ef4a9b] \n"
+ "[case #2ef4a9b] \n"
+ "[case #96be035] \n"
+ "[case #fc043fa] \n"
+ "[case #2ed20ad] \n"
+ "[case #7131fec] ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}