import re
regex = re.compile(r"(\[case #(?>[0-9a-f]){7}\] )", flags=re.MULTILINE)
test_str = ("[case #2ef4a9b] \n"
"[case #2ef4a9b] \n"
"[case #96be035] \n"
"[case #fc043fa] \n"
"[case #2ed20ad] \n"
"[case #7131fec] ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")