$re = '/(\[case #(?>[0-9a-f]){7}\] )/m';
$str = '[case #2ef4a9b]
[case #2ef4a9b]
[case #96be035]
[case #fc043fa]
[case #2ed20ad]
[case #7131fec] ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);