#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)b[0-9]{4}(*SKIP)(*F)|[^a-z_]"
Local $sString = "b7001_cp_parc_venc_fluxo_1234" & @CRLF & _
"b7001_cp_parc_venc_fluxo_1234 b7001_cp_parc_venc_fluxo_1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")