import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "b[0-9]{4}(*SKIP)(*F)|[^a-z_]";
final String string = "b7001_cp_parc_venc_fluxo_1234\n"
+ "b7001_cp_parc_venc_fluxo_1234 b7001_cp_parc_venc_fluxo_1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}