$re = '/b[0-9]{4}(*SKIP)(*F)|[^a-z_]/m';
$str = 'b7001_cp_parc_venc_fluxo_1234
b7001_cp_parc_venc_fluxo_1234 b7001_cp_parc_venc_fluxo_1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);