// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)b[0-9]{4}(*SKIP)(*F)|[^a-z_]").unwrap();
let string = "b7001_cp_parc_venc_fluxo_1234
b7001_cp_parc_venc_fluxo_1234 b7001_cp_parc_venc_fluxo_1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}