const regex = /(?<board>.*)\s?branch:(?<branch>.*)\s+sdk:(?<sdk>.*)\s+foundation:(?<foundation>.*)\s+tegra:(?<tegra>.*)\s+dgpu:(?<dgpu>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<board>.*)\\s?branch:(?<branch>.*)\\s+sdk:(?<sdk>.*)\\s+foundation:(?<foundation>.*)\\s+tegra:(?<tegra>.*)\\s+dgpu:(?<dgpu>.*)', 'gm')
const str = `branch:embedded-5.2.9.0 sdk:0003 foundation:0003 tegra:x1 dgpu:TU104-600-CS`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}