$re = '/(?<board>.*)\s?branch:(?<branch>.*)\s+sdk:(?<sdk>.*)\s+foundation:(?<foundation>.*)\s+tegra:(?<tegra>.*)\s+dgpu:(?<dgpu>.*)/m';
$str = 'branch:embedded-5.2.9.0 sdk:0003 foundation:0003 tegra:x1 dgpu:TU104-600-CS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);