# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\[@[A-Za-z0-9]+\])//gm;t' <<< "Hello [@foo] how are you [@bar] more text
Hello [@foauAOFUAFL] how are you [@08adfAF] more text"