const regex = /(?:\[@[A-Za-z0-9]+\])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\[@[A-Za-z0-9]+\\])', 'gm')
const str = `Hello [@foo] how are you [@bar] more text
Hello [@foauAOFUAFL] how are you [@08adfAF] more text`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);