import Foundation
let pattern = #"(?:\[@[A-Za-z0-9]+\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hello [@foo] how are you [@bar] more text
Hello [@foauAOFUAFL] how are you [@08adfAF] more text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)