using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\[@[A-Za-z0-9]+\])";
string substitution = @"";
string input = @"Hello [@foo] how are you [@bar] more text
Hello [@foauAOFUAFL] how are you [@08adfAF] more text";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}