#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[- 0-9]*"
Local $sString = "2025715-01 -2025715-Test_482080 " & @CRLF & _
"2025715-02 -2025715-Test1 (2015-7-9 19_11_3) " & @CRLF & _
"2025715-03 -2025715-Test2_482080 - signed " & @CRLF & _
"2025715-04 -2025715-Test3 " & @CRLF & _
"2025715-11 -2025715-Test4, PTO " & @CRLF & _
"2025715-13 -2025715-Test5 " & @CRLF & _
"2025734-01 -2025734-Test6_402772 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")