re = /^[- 0-9]*/m
str = '2025715-01 -2025715-Test_482080
2025715-02 -2025715-Test1 (2015-7-9 19_11_3)
2025715-03 -2025715-Test2_482080 - signed
2025715-04 -2025715-Test3
2025715-11 -2025715-Test4, PTO
2025715-13 -2025715-Test5
2025734-01 -2025734-Test6_402772 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end