use strict;
my $str = '2025715-01 -2025715-Test_482080
2025715-02 -2025715-Test1 (2015-7-9 19_11_3)
2025715-03 -2025715-Test2_482080 - signed
2025715-04 -2025715-Test3
2025715-11 -2025715-Test4, PTO
2025715-13 -2025715-Test5
2025734-01 -2025734-Test6_402772 ';
my $regex = qr/^[- 0-9]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}