import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[- 0-9]*";
final String string = "2025715-01 -2025715-Test_482080 \n"
+ "2025715-02 -2025715-Test1 (2015-7-9 19_11_3) \n"
+ "2025715-03 -2025715-Test2_482080 - signed \n"
+ "2025715-04 -2025715-Test3 \n"
+ "2025715-11 -2025715-Test4, PTO \n"
+ "2025715-13 -2025715-Test5 \n"
+ "2025734-01 -2025734-Test6_402772 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}