const regex = /^[- 0-9]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[- 0-9]*', 'gm')
const str = `2025715-01 -2025715-Test_482080
2025715-02 -2025715-Test1 (2015-7-9 19_11_3)
2025715-03 -2025715-Test2_482080 - signed
2025715-04 -2025715-Test3
2025715-11 -2025715-Test4, PTO
2025715-13 -2025715-Test5
2025734-01 -2025734-Test6_402772 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}