#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=>)[\w\s\p{P}]+(?=<)"
Local $sString = "hi<p>test1</p>" & @CRLF & _
"<p>test2 <span class="theClass">text3</span></p>" & @CRLF & _
"<a href="test">text</a>" & @CRLF & _
"hi" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")