import re
regex = re.compile(r"(?<=>)[\w\s\p{P}]+(?=<)")
test_str = ("hi<p>test1</p>\n"
"<p>test2 <span class=\"theClass\">text3</span></p>\n"
"<a href=\"test\">text</a>\n"
"hi\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")