using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=>)[\w\s\p{P}]+(?=<)";
string input = @"hi<p>test1</p>
<p>test2 <span class=""theClass"">text3</span></p>
<a href=""test"">text</a>
hi
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}