$re = '/(?<=>)[\w\s\p{P}]+(?=<)/';
$str = 'hi<p>test1</p>
<p>test2 <span class="theClass">text3</span></p>
<a href="test">text</a>
hi
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);