const regex = new RegExp('(?<=>)[\\w\\s\\p{P}]+(?=<)', 'g')
const str = `hi<p>test1</p>
<p>test2 <span class="theClass">text3</span></p>
<a href="test">text</a>
hi
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}