#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[\[(?:[^|\]]*\|)?(.*?)\]\]"
Local $sString = "[[wiki page|display text]]" & @CRLF & _
"[[wiki page]]" & @CRLF & _
"[[wiki page]] [[wiki page|display text]]"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)