// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[\[(?:[^|\]]*\|)?(.*?)\]\]").unwrap();
let string = "[[wiki page|display text]]
[[wiki page]]
[[wiki page]] [[wiki page|display text]]";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}