using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[(?:[^|\]]*\|)?(.*?)\]\]";
string substitution = @"$1";
string input = @"[[wiki page|display text]]
[[wiki page]]
[[wiki page]] [[wiki page|display text]]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}