re = /\[\[(?:[^|\]]*\|)?(.*?)\]\]/
str = '[[wiki page|display text]]
[[wiki page]]
[[wiki page]] [[wiki page|display text]]'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result