package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\[(?:[^|\]]*\|)?(.*?)\]\]`)
var str = `[[wiki page|display text]]
[[wiki page]]
[[wiki page]] [[wiki page|display text]]`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}