# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b([CDEFGAB](?:b|bb)*(?:#|##|sus|maj|min|aug)*[\d\\/]*(?:[CDEFGAB](?:b|bb)*(?:#|##|sus|maj|min|aug)*[\d\\/]*)*)(?=\s|$)(?! \w))/[$1]/gm;t' <<< "Db Dsus4/F# A Cbmin/C
A man can't be asked for that much to do
D/F# G A D#/E F#min/E
And I can't sweep you off of your feet"