import Foundation
let pattern = ###"(\b([CDEFGAB](?:b|bb)*(?:#|##|sus|maj|min|aug)*[\d\/]*(?:[CDEFGAB](?:b|bb)*(?:#|##|sus|maj|min|aug)*[\d\/]*)*)(?=\s|$)(?! \w))"###
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Db Dsus4/F# A Cbmin/C
A man can't be asked for that much to do
D/F# G A D#/E F#min/E
And I can't sweep you off of your feet
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[$1]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)