re = /(\b([CDEFGAB](?:b|bb)*(?:#|##|sus|maj|min|aug)*[\d\/]*(?:[CDEFGAB](?:b|bb)*(?:#|##|sus|maj|min|aug)*[\d\/]*)*)(?=\s|$)(?! \w))/m
str = 'Db Dsus4/F# A Cbmin/C
A man can\'t be asked for that much to do
D/F# G A D#/E F#min/E
And I can\'t sweep you off of your feet'
subst = '[$1]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result