const regex = /(\b([CDEFGAB](?:b|bb)*(?:#|##|sus|maj|min|aug)*[\d\/]*(?:[CDEFGAB](?:b|bb)*(?:#|##|sus|maj|min|aug)*[\d\/]*)*)(?=\s|$)(?! \w))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b([CDEFGAB](?:b|bb)*(?:#|##|sus|maj|min|aug)*[\\d\\\/]*(?:[CDEFGAB](?:b|bb)*(?:#|##|sus|maj|min|aug)*[\\d\\\/]*)*)(?=\\s|$)(?! \\w))', 'gm')
const str = `Db Dsus4/F# A Cbmin/C
A man can't be asked for that much to do
D/F# G A D#/E F#min/E
And I can't sweep you off of your feet`;
const subst = `[$1]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);