#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*2160)(?=.*ATVP)(?=.*DV).*"
Local $sString = "Title.2160p.ATVP.WEB.DV.x265-Rls" & @CRLF & _
"Title.2160p.DV.WEB.ATVP.x265-Rls" & @CRLF & _
"Title.ATVP.2160p.WEB.DV.x265-Rls" & @CRLF & _
"Title.1080p.WEB.ATVP.x265-Rls" & @CRLF & _
"Title.2160p.WEB.DV.x265-Rls" & @CRLF & _
"Title.2160p.BluRay.x265-Rls"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")