re = /(?=.*2160)(?=.*ATVP)(?=.*DV).*/m
str = 'Title.2160p.ATVP.WEB.DV.x265-Rls
Title.2160p.DV.WEB.ATVP.x265-Rls
Title.ATVP.2160p.WEB.DV.x265-Rls
Title.1080p.WEB.ATVP.x265-Rls
Title.2160p.WEB.DV.x265-Rls
Title.2160p.BluRay.x265-Rls'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end