import Foundation
let pattern = #"(?=.*2160)(?=.*ATVP)(?=.*DV).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Title.2160p.ATVP.WEB.DV.x265-Rls
Title.2160p.DV.WEB.ATVP.x265-Rls
Title.ATVP.2160p.WEB.DV.x265-Rls
Title.1080p.WEB.ATVP.x265-Rls
Title.2160p.WEB.DV.x265-Rls
Title.2160p.BluRay.x265-Rls
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)