use strict;
my $str = 'Title.2160p.ATVP.WEB.DV.x265-Rls
Title.2160p.DV.WEB.ATVP.x265-Rls
Title.ATVP.2160p.WEB.DV.x265-Rls
Title.1080p.WEB.ATVP.x265-Rls
Title.2160p.WEB.DV.x265-Rls
Title.2160p.BluRay.x265-Rls';
my $regex = qr/(?=.*2160)(?=.*ATVP)(?=.*DV).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}