$re = '/(?=.*2160)(?=.*ATVP)(?=.*DV).*/m';
$str = 'Title.2160p.ATVP.WEB.DV.x265-Rls
Title.2160p.DV.WEB.ATVP.x265-Rls
Title.ATVP.2160p.WEB.DV.x265-Rls
Title.1080p.WEB.ATVP.x265-Rls
Title.2160p.WEB.DV.x265-Rls
Title.2160p.BluRay.x265-Rls';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);