#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[1][0-5]$"
Local $sString = "1" & @CRLF & _
"0" & @CRLF & _
"9" & @CRLF & _
"10" & @CRLF & _
"11" & @CRLF & _
"12" & @CRLF & _
"13" & @CRLF & _
"14" & @CRLF & _
"15" & @CRLF & _
"16" & @CRLF & _
"123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")