const regex = /^[1][0-5]$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1][0-5]$', 'gim')
const str = `1
0
9
10
11
12
13
14
15
16
123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}