package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^[1][0-5]$`)
var str = `1
0
9
10
11
12
13
14
15
16
123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}