import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1][0-5]$";
final String string = "1\n"
+ "0\n"
+ "9\n"
+ "10\n"
+ "11\n"
+ "12\n"
+ "13\n"
+ "14\n"
+ "15\n"
+ "16\n"
+ "123";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}