$re = '/^[1][0-5]$/im';
$str = '1
0
9
10
11
12
13
14
15
16
123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);