#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!"config").)*$"
Local $sString = "{"httpStatus": "OK", "payload": {"status": "OK"}, "httpCode": 200}" & @CRLF & _
"" & @CRLF & _
"{"httpStatus": "OK", "payload": {"config": "OK"}, "httpCode": 200}" & @CRLF & _
"" & @CRLF & _
"{"httpStatus": "OK", "payload": {"status": "OK"}, "httpCode": 200}" & @CRLF & _
"" & @CRLF & _
"{"httpStatus": "OK", "payload": {"configure": "OK"}, "httpCode": 200}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{"httpStatus": "OK", "payload": {"con": "config"}, "httpCode": 200}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")