import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!\"config\").)*$";
final String string = "{\"httpStatus\": \"OK\", \"payload\": {\"status\": \"OK\"}, \"httpCode\": 200}\n\n"
+ "{\"httpStatus\": \"OK\", \"payload\": {\"config\": \"OK\"}, \"httpCode\": 200}\n\n"
+ "{\"httpStatus\": \"OK\", \"payload\": {\"status\": \"OK\"}, \"httpCode\": 200}\n\n"
+ "{\"httpStatus\": \"OK\", \"payload\": {\"configure\": \"OK\"}, \"httpCode\": 200}\n\n\n"
+ "{\"httpStatus\": \"OK\", \"payload\": {\"con\": \"config\"}, \"httpCode\": 200}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}