using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!""config"").)*$";
string input = @"{""httpStatus"": ""OK"", ""payload"": {""status"": ""OK""}, ""httpCode"": 200}
{""httpStatus"": ""OK"", ""payload"": {""config"": ""OK""}, ""httpCode"": 200}
{""httpStatus"": ""OK"", ""payload"": {""status"": ""OK""}, ""httpCode"": 200}
{""httpStatus"": ""OK"", ""payload"": {""configure"": ""OK""}, ""httpCode"": 200}
{""httpStatus"": ""OK"", ""payload"": {""con"": ""config""}, ""httpCode"": 200}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}