const regex = new RegExp('^((?!"config").)*$', 'gm')
const str = `{"httpStatus": "OK", "payload": {"status": "OK"}, "httpCode": 200}
{"httpStatus": "OK", "payload": {"config": "OK"}, "httpCode": 200}
{"httpStatus": "OK", "payload": {"status": "OK"}, "httpCode": 200}
{"httpStatus": "OK", "payload": {"configure": "OK"}, "httpCode": 200}
{"httpStatus": "OK", "payload": {"con": "config"}, "httpCode": 200}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}